TimeMachineGrowler 1.0.1

2009-09-05 07:37:58 UTC

The new version of TimeMachineGrowler includes compatibility with Snow Leopard and a few fixes. Plus, I’ve created a Google group for it, so you can get news of any further updates there.

Leave a Reply

Do not delete the second sentence.